Forum

Welcome to Floola's community forum. Here you'll most probably find an answer to any problem you might have with Floola.
 
Save you some time and before starting a new post please search the forum, there could already be an answer to your question!
 
You should also take a minute to look at the online documentation where you'll most topics covered.
 
 
 

elan
Member
Posts: 6

Hi,

The prioblem I have is podcast episodes are downloaded, but not added to the iPod anymore. This is what happened. I used Floola on Ubuntu (now 10.04) for a long time. I was still using 6.1. Last 2 weeks on holiday I only had a Windows (Win7) laptop with me. I had Floola-win on the iPod, so I used that. I did not download any podcasts with it, just added and deleted some audiobook-mp3-files that where on the laptop.

Upon returing home I connected my iPod to the Ubuntu machine and started downloading 9 podcast episodes: 4 where added to the iPod, the other 5 failed.

I then tried downloading the other 5 with Floola-win on the laptop I used during holidays: these 5 episodes downloaded, but where not added. So I tried Floola 2011r3 on Ubuntu, same problem. Finally I installed iTunes in a VM and used that to sync all podcast subsciptions and podcast episodes I wanted on the iPod. That worked.

Then I connected the iPod to Floola on the Ubuntu machine. I got the message that a unknown version of iTunes had been used, it may give problems, and I shuold report this. I tried what would happen if I continued, so I downloaded another podcast episode that had just been released. That worked OK and the episode was downloaded and installed on the iPod. Later I tried to add more podcast episodes that had been released. But after that initial one that was installed, additional podcasts episodes are downloaded, but not installed again.

I also tried this again on the Win7 laptop with Floola, but that does not work either.

This is a 6th-gen iPod classic 60Gb.

Please help, as I do not like to have to use iTunes in the VM or on the Win7 laptop to manange podcasts on my iPod.

TIA, elan.

Sid32
Moderator
Posts: 635

1. Ignore that part about a new version of itunes. You are just using a version of itunes that come out after the last floola version.

2. can you post the rss feed you use of the podcasts and what eps. are giving you trouble. I assume all are audio, not video podcasts?

3. Can you download the podcasts from your browser/rss reader to your desktop and add them with Floola?

4. Can you do a search of your ipod for them? Maybe they were put under audio books, etc..

5. You can see the podcasts being downloaded or do they time out?

6. Does Floola crash when it fails to add or displays any error msg?

7. Can you do a search for lost files or files not in the itunes database with Floola. See if they turn up that way.

elan
Member
Posts: 6

Hi,

First: the problem has been solved. See below for details. The requested information:

2. can you post the rss feed you use of the podcasts and what eps. are giving you trouble. I assume all are audio, not video podcasts?

They where both audio and video podcasts. The feeds I tried where:
http://pauldotcom.com/podcast/psw.xml
http://mckeay.libsyn.com/rss
http://feeds.feedburner.com/NetworkSecurityPodcast
http://leo.am/podcasts/floss
http://feeds.feedburner.com/MarkCogginsPodcast
http://www.nasa.gov/rss/NASAcast_podcast.rss
http://www.nasa.gov/rss/NASAcast_vodcast.rss
http://revision3.com/haktip/feed/MP4-Small
(Only the last 2 are video feeds)

3. Can you download the podcasts from your browser/rss reader to your desktop and add them with Floola?

Yes, that is precisely what I had been doing during my holidays with Floola on the Win7 laptop: download manually, add manually. That was with previous episodes from the same feeds and with episodes from other feeds.

4. Can you do a search of your ipod for them? Maybe they were put under audio books, etc..

When I downloaded and added the older episodes manually during my holidays I added the podcast episodes as audiobooks just to get them in a different category then my music.

But the ones I tried to download from the RSS-feeds when I had these problems, where never actually added after downloading. Also not as audiobooks orso.

5. You can see the podcasts being downloaded or do they time out?
Yes, I can see the podcasts being downloaded at normal speed: the blue down-arrow appears in front of the line and the progress bar counts up (megabytes, at the end of the line) until the mp3/mp4 is downloaded.

Normally the line would turn green after that, when the item (audio/video) is being added to the iPod database etc. and after that is appears with a blue bullet in front, as a new episode.

When I had the problems, the line would not turn green, and would not get the blue bullet in front. Instead, after a while, a triangle with a red exclamation mark would appear in front of the line. And the checkbox allowing me to download it again, would be checked again.

6. Does Floola crash when it fails to add or displays any error msg?
No crash, no error message. After downloading the I would just wait for about the time the line normally is green, and then display the triangle with the red exclamation mark. Hovering my mouse over the triangle would not popup a message indicating what was wrong.

7. Can you do a search for lost files or files not in the itunes database with Floola. See if they turn up that way.

I have found 104 lost files. I have since tried several other iPod Managers for Linux (gtkpod+gpodder, Banshee, Rhythmbox). Soo these experiments may also have caused the lost files. So I’ll see by the date whether I can determine which program caused the file to get lost.

This is the breakdown:
- 18 files have libgpod in the name, so are not caused by Floola but the other experiments. This is confirmed by the timestamp on the files: July 27th, 11:02 and 11:03, so after I posted my initial bugreport, when I had started testing other iPod Managers.
- 2 are old episodes added before I noticed/had the problems.
- 2 are MP3′s with the same date as these 2 episodes (March 2nd, 2011). Maybe I had not closed down Floola before unmounting the iPod on March 2nd (that sometimes happens)?
- 1 file (called mp4) is from June 1st. It is a Space Shuttle landing video from the NASACast Video RSS-feed (http://www.nasa.gov/rss/NASAcast_vodcast.rss). This may also be an unmount-before-Floola-closedown “accident”.
- all other files are from July 27th between 11:02 and 23:34, soo they are all from my experiments with the other iPod Managers and are not caused by Floola.

So how did I solve the problem?
I got tired of trying other iPod managers. They all had (more) things that didn’t work compared Floola. Soo, I decided to try and get Floola working. I did that as follows:
- cd to /media/IPOD/iPod_Control/Floola
- mkdir bkup
- copy iTunesDB to bkup
- copy latest_working to bkup
- ls -lrt
# try to determine by date which database had been created before I had experienced the problems.
- copy that database to iTunesDB and to latest_working
- started Floola
- added podcasts, everything works.

Thanks for the help.

Sid32
Moderator
Posts: 635

Thanks man. Pro level post. It should be helpful for others as well.

I will add that everyone should back-up their ipod_control/itunes folder ~25 megs every so often, and when they big changes to their music on the ipod.

I will also throw out that if this happens to anyone again on vacation, you can make a smart playlist to keep all your podcasts together.

and if you updating you can always make a new folder for the old Floola version. Ie. Floola-win_old, that way you can backup Floola as well.

elan
Member
Posts: 6

Hi,

Thanks.

I’m sorry to say the problem has re-appeared, only with specific podcast feeds this time. The problematic feeds are:
http://feeds.feedburner.com/MarkCogginsPodcast
http://feeds.feedburner.com/BicyclemarksCommunique
http://feeds.feedburner.com/bicyclemarkspodcast
(strangely not with: http://feeds.feedburner.com/bicyclemarksvlog (is of the same author))

I can download these with my browser without problem. They do not end up as lost files.

elan.


Sid32
Moderator
Posts: 635

Yeah, im getting some problems with them as well. Downloads and then I get the Yield triangle with ‘!’ in it.

Pages: [1]
To take part in the discussions please login or register
 
  
Register  /  Lost password?